Forum
Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ReportPortal General Forum
 Report Portal General Issues
 OLAP Security
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

zablos

17 Posts

Posted - 11/03/2014 :  09:44:34  Show Profile  Reply with Quote
Hi

I'd like to add user with possibilities to create OLAP report
with restriction to specific Cubes in one database.

admin

1609 Posts

Posted - 11/03/2014 :  20:06:22  Show Profile  Reply with Quote
In BIDS, create an SSAS role (Role1). Click on the Cubes tab and select the read access to your cube. Optionally (for steps 2 or 3 below), click on the Membership tab and add a Windows user.
Now you have three options to link the SSAS role to a ReportPortal user:

1. Go to Admin > User > under XMLA properties type: Roles=Role1;
2. In IIS admin, select the XMLA virtual directory set basic authentication. Go to Admin > User > select the user and enter the Windows user name and password you used in the SSAS role. Go to Admin > Settings > OLAP Report >and check: “XML for Analysis Security Enabled”
3. In IIS admin, select the XMLA virtual directory set anonymous authentication. For the Anonymous user to windows user you used in the SSAS role.

Each option has its pros and cons.
Go to Top of Page

WildCard

89 Posts

Posted - 02/23/2018 :  07:17:56  Show Profile  Reply with Quote
Hi there,

I've created a role (User) with restricted dimension data for a cube in SQL Server Management Studio and inserted Roles=User; in XMLA properties of a Report Portal user. However, when I log in with that user I can via OLAP report connect to the cube, but still get full access to the restricted dimension. Have I missed something out?
Go to Top of Page

admin

1609 Posts

Posted - 02/23/2018 :  11:16:18  Show Profile  Reply with Quote
The XMLA Properties can be set on user, role and connection levels. They are cumulative. Please make sure that "Roles=" is set only on the user level.
Go to Top of Page

WildCard

89 Posts

Posted - 02/26/2018 :  00:45:34  Show Profile  Reply with Quote
It is only set on the user directly. No Properties set on the role or connection. Btw, in IIS the XMLA directory is set to anonymous authentication. Do I have to use basic auth for the XMLA properties to work?
Go to Top of Page

admin

1609 Posts

Posted - 02/26/2018 :  06:07:26  Show Profile  Reply with Quote
Which build do you have (Admin > Settings > Version)?
Go to Top of Page

WildCard

89 Posts

Posted - 02/26/2018 :  06:12:25  Show Profile  Reply with Quote
Build 191
Go to Top of Page

admin

1609 Posts

Posted - 02/26/2018 :  22:12:46  Show Profile  Reply with Quote
Build 191 has a problem with XMLA properties. Can you upgrade to the newest build 198?

Do you see this problem in the view or the design mode?
Go to Top of Page

WildCard

89 Posts

Posted - 02/27/2018 :  02:19:35  Show Profile  Reply with Quote
I figured out now that the XMLA property actually works, but you have to add the restricted dimension to the filters in design mode. The filter then only shows the members the user should have access to, effectively restricting the data her can see. Otherwise, if you don't add the dimension as a filter the user can see all members as default in design and view mode.

Unfortunately, I don't have the possibilty to upgrade to Build 198 in the near future. Is it possible for you to provide a hotfix or would the effort be too high?
Go to Top of Page

admin

1609 Posts

Posted - 02/27/2018 :  22:59:10  Show Profile  Reply with Quote
Sorry but generating this patch for 191 might take few days.

Please make sure your support is up to date.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Forum © ReportPortal Go To Top Of Page
Snitz Forums 2000