Forum
Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ReportPortal General Forum
 Report Portal Installation
 Windows Server 2012 R2 Datacenter
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

marco

Netherlands
588 Posts

Posted - 01/14/2014 :  09:32:30  Show Profile  Reply with Quote
Hello,

We have installed ReportPortal 4.0 on Windows Server 2012 R2 Datacenter.

If you have some questions or IIS setup instructions, please let us know.

Best regards,
Marco

stevek

Australia
22 Posts

Posted - 02/18/2014 :  18:18:29  Show Profile  Reply with Quote
We are having SSO issues with build 183 on 2012 Datacenter.

All settings look to be configured correctly, however when I run the Enable Pass-Through Authentication test under Admin-->Security-->Application Settings I get back that its trying to run as %localhost%\Administrator instead of my domain based user account, this feels likes its not authenticating against the domain.

IIS is set to Basic and Windows Auth for the Site so this should work, but I feel like im missing an ldap config string somewhere.

Edited by - stevek on 02/18/2014 18:30:38
Go to Top of Page

admin

1610 Posts

Posted - 02/18/2014 :  21:14:25  Show Profile  Reply with Quote
Please set your domain: Admin > Settings > Security > Windows Domain Name
Go to Top of Page

stevek

Australia
22 Posts

Posted - 02/18/2014 :  22:43:10  Show Profile  Reply with Quote
yes that setting is correct.

when I also go into the Admin-->Connections-->Pick a connection and try & test it, it also tries to pass the creds as %loclahost%\Administrator
Go to Top of Page

admin

1610 Posts

Posted - 02/18/2014 :  23:32:53  Show Profile  Reply with Quote
Are you connecting to SSAS (XMLA) or SQL Server database engine?

To enable SSAS Windows Security please follow steps below:

1. Go to Admin > Settings > OLAP Report. Check the "XML for Analysis Security Enabled" option and click Update.
2. Using IIS console change XMLA Virtual directory to use basic authentication only.
3. To set security for a user go to Admin > Users. Enter Windows user id and password and click Update. You can use the same Windows user id and password for multiple users.
4. To set security for a group of users go to Admin > Roles. Enter Windows user id and password and click Update.
Go to Top of Page

stevek

Australia
22 Posts

Posted - 02/19/2014 :  15:38:20  Show Profile  Reply with Quote
All those settings are correct.

I did however manage to find the incorrect config setting, it was in fact IIS on the root of the site under Advanced settings-->Physical Path Credentials was set to use the local admin account. Instead of pass through.

Thanks very much for your help and assistance.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Forum © ReportPortal Go To Top Of Page
Snitz Forums 2000