Report Portal
Report Portal
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ReportPortal General Forum
 Report Portal General Issues
 Subscription Excel report % formatting issue
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic Next Topic  

m.andrysz

United Kingdom
4 Posts

Posted - 11/18/2022 :  04:30:48  Show Profile  Reply with Quote
Hi,

It looks like since we upgraded to 2.1 ver. excel reports produced via subscriptions are having some issues with percentage formatting when the value is above 1.0 (i.e. 1.20 - 120%) it does not put % format on them. It does format properly when the report is exported manually.

Regards,
MA

admin

1633 Posts

Posted - 11/21/2022 :  08:02:54  Show Profile  Reply with Quote
What type of Report is it (OLAP, SQL, SSRS)?
What is your build (Admin > Settings > Version)?
Go to Top of Page

m.andrysz

United Kingdom
4 Posts

Posted - 11/21/2022 :  11:17:03  Show Profile  Reply with Quote
quote:
[i]Originally posted by admin[/i]
[br]What type of Report is it (OLAP, SQL, SSRS)?
What is your build (Admin > Settings > Version)?




Hi,

It is the OLAP report.

Regards,
MA
Go to Top of Page

admin

1633 Posts

Posted - 11/21/2022 :  15:42:46  Show Profile  Reply with Quote
What is your build (Admin > Settings > Version)?
Go to Top of Page

admin

1633 Posts

Posted - 11/21/2022 :  22:47:40  Show Profile  Reply with Quote
Can you please help to reproduce this problem on the demo server?

http://www.reportportal.us/ReportPortal/design/view.aspx?reportId=2707
Go to Top of Page

m.andrysz

United Kingdom
4 Posts

Posted - 11/24/2022 :  03:03:27  Show Profile  Reply with Quote
quote:
[i]Originally posted by admin[/i]
[br]What is your build (Admin > Settings > Version)?




Hi,
It is:
Build Number: ReportPortal 6.0, Build 207, Sep 6, 2022

Regards,
MA
Go to Top of Page

m.andrysz

United Kingdom
4 Posts

Posted - 11/24/2022 :  03:34:57  Show Profile  Reply with Quote
quote:
[i]Originally posted by admin[/i]
[br]Can you please help to reproduce this problem on the demo server?

http://www.reportportal.us/ReportPortal/design/view.aspx?reportId=2707




Hi,

I'm not sure how can I reproduce this error on your server. I created a report " Report - Subscription Excel report % formatting!" but the issue only appears for the reports distributed via subscriptions and I can't see my username, to be able to set up the subscription. Who would you like me to set the report to be sent to?

Also, It happens only for the conditionally formatted fields.

Regards,
MA

Edited by - m.andrysz on 11/24/2022 03:38:49
Go to Top of Page

admin

1633 Posts

Posted - 11/25/2022 :  10:59:14  Show Profile  Reply with Quote
Yes, conditional formatting seems to be the key to reproducing the problem. It can be reproduced without the subscription if the paging is on.
Go to Top of Page

admin

1633 Posts

Posted - 11/25/2022 :  13:54:18  Show Profile  Reply with Quote
Please try this patch:

1. Download and unzip: https://reportportal.com/download/rp_207_RpScheduler2.zip

2. Stop RP Scheduler service

3. Backup old file and copy the unzipped files to:
bin\ReportPortal.dll
bin\RpScheduler.exe

4. Start RP Scheduler service
Go to Top of Page
   Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Report Portal © RP Go To Top Of Page