Forum
Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ReportPortal General Forum
 Report Portal General Issues
 Subscriptions broken after live update
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic Next Topic  

bbloese

USA
9 Posts

Posted - 11/08/2018 :  22:23:25  Show Profile  Reply with Quote
I used live update to go from build 199 to 200. After the update when a subscription runs an error with no details is logged in the Subscriptions History tab. Nothing is logged in the windows event viewer.

https://snag.gy/BFSunf.jpg

admin

1563 Posts

Posted - 11/08/2018 :  22:36:30  Show Profile  Reply with Quote
Sounds line the database changes have not beet applied. Please run UpdateDb.vbs. You can also try to apply the database change manually:


ALTER TABLE dbo.Job ADD DelivFilePattern nvarchar(200) NULL
Go to Top of Page

bbloese

USA
9 Posts

Posted - 11/08/2018 :  22:50:54  Show Profile  Reply with Quote
I ran UpdateDb.vbs and verified that the DelivFilePattern column is present in the job table. However there is no change, subscriptions are still posting a blank error message.
Go to Top of Page

bbloese

USA
9 Posts

Posted - 11/08/2018 :  23:05:51  Show Profile  Reply with Quote
The issue seems to be isolated to subscriptions that with a content type of PDF. When running OLAP reports with a PDF content type I get the following error:

Could not load file or assembly 'itextsharp, Version=4.1.6.0, Culture=neutral, PublicKeyToken=8354ae6d2174ddca' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Edited by - bbloese on 11/09/2018 07:27:07
Go to Top of Page

bbloese

USA
9 Posts

Posted - 11/09/2018 :  11:48:48  Show Profile  Reply with Quote
After completing the steps below Iím now able to run OLAP subscriptions that email PDFs.

1. Run UpdateDb.vbs and verified the DelivFilePatther colum is present in the Job table.

2. Updated the itextsharp.dll file in C:\inetpub\wwwroot\ReportPortal\bin\ http://reportportal.com/download/itextsharp.zip

3. Updated the RpScheduler.exe file in C:\inetpub\wwwroot\reportportal_200\bin http://www.reportportal.com/download/rp_200_RpScheduler.zip


However Iím still unable to run Cyrstal Report subscriptions. The subscriptions error out with a blank view history window. https://snag.gy/Tc1qDj.jpg
Go to Top of Page

admin

1563 Posts

Posted - 11/11/2018 :  16:38:50  Show Profile  Reply with Quote
Please try this fix. It will show the error for each history record even if it cannot be tied to a user.

1. Download and unzip: http://www.reportportal.com/download/rp_200_ViewHistory.zip
2. Backup old file and copy the unzipped file to: "C:\inetpub\wwwroot\ReportPortal(_200)\bin\ReportPortal.dll"
Go to Top of Page
   Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Forum © ReportPortal Go To Top Of Page
Snitz Forums 2000